Is it possible to create a layer 3 port-channel using the VLAN interface on a L3 switch to a IOS XE Router interface? For example, using GNS3 I set the L3 switch as the core with multiple routers in a port-channel connected to it. The port-channel formed, I can ping one another, and I can see the neighbor relationship. My worry though is that when I check the etherchannel summary of both devices, the L3 switch says it is a Layer 2 channel (SU) while the RTR says it is a Layer 3 channel (RU). Will this cause any issues with devices or networks that will be behind this router? Can I connect more routers to the switch in the same method using the same VLAN interface on the L3 switch? Maybe I'm reading too much into it. but the layer 2 channel to layer 3 channel is really confusing me. Any remark is appreciated!!
Relevant config example:
-----L3 Switch------
interface Port-channel1
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet0/1
switchport access vlan 10
switchport mode access
negotiation auto
channel-group 1 mode active
!
interface GigabitEthernet0/2
switchport access vlan 890
switchport mode access
negotiation auto
channel-group 1 mode active
!
interface Vlan10
ip address 10.0.10.1 255.255.255.0
!
router eigrp 100
network 10.0.0.0
----RTR----
interface Port-channel1
ip address 10.0.10.2 255.255.255.0
!
interface GigabitEthernet1
no ip address
channel-group 1 mode active
!
interface GigabitEthernet2
no ip address
channel-group 1 mode active
!
router eigrp 100
network 10.0.0.0
No comments:
Post a Comment