Sunday, March 14, 2021

Redistribute BGP routes to OSPF stub, LSA-5 external, how to allow them to routing table

TLDR:

To BGP: redistribute ospf - Works

To OSPF: redistribute bgp - Does not, due to LSA-5 not going to OSPF Stub area

Not contradict to documentation, but how to make it working?

__________________________

I have a hub and spoke setup of 2 pfSense routers and 1 hub node between them

[Router-A, LAN 192.168.56.0/24] -- <VPN + BGP> -- [Hub FRRouting + ospf + bgp] -- <VPN + OSPF> -- [Router-B, LAN 172.25.31.0/24]

On the hub I redistribute OSPF routes to BGP and BGP to OSPF. On BGP side (Left: 192.168.56.0/24) I can ping OSPF side (right 172.25.31.0/24 )E.g., "ping 172.25.31.1" works

However, issue is with redistributing BGP to OSPF, hence BGP routes are of LSA-5, external routes, https://docs.frrouting.org/en/latest/ospfd.html#redistribution

On OSPF side, I see it as:

AS External Link States

Link ID ADV Router Age Seq# CkSum Route

192.168.56.0 172.23.76.3 222 0x8000000c 0xd20b E2 192.168.56.0/24 [0x0]

Where 172.23.76.3 is my hub router ID.

192.168.56.0/24 is not added to the router internal routing table. So this subnet is served via default gateway, it won't go anywhere and I can't access the BGP side

Question is, how can I redistribute BGP on the hub to OSPF, so, on the OSPF router BGP routes are added to the routing table?

_________________________________

Hub ospf.conf:

hostname ospfd

password password

log stdout

!

interface tap0

description GM Ospf Mesh, tinc

ip ospf network point-to-multipoint

ip ospf cost 10

!

interface lo:0

description Host loopback

!

router ospf

ospf router-id 172.23.76.3

redistribute bgp

passive-interface default

no passive-interface tap0

network 172.23.79.0/24 area 0

!

line vty

!

"tap0" is spanning L2 VPN network, 172.23.79.0/24
_________________________________

OSPF side router:

password password

log syslog

interface em1

interface tap0

ip ospf network point-to-multipoint

ip ospf mtu-ignore

ip ospf cost 10

router ospf

ospf router-id 172.23.76.15

passive-interface default

no passive-interface tap0

network 172.25.31.0/24 area 0

network 172.23.79.0/24 area 0

tap0 - is VPN, em1 - LAN, 172.25.31.0/24



No comments:

Post a Comment