Sunday, December 15, 2019

Dual ISP/Core sanity check

Over the past couple days we have brought up a second core and a second ISP connection. We will be sending and receiving traffic on both ISPs. Both have the same 10Gb speeds. ISP1 we are receiving full tables and have a BGP session setup. ISP2 will have the capability to do BGP in the next month or 2 because of hardware upgrades. We will receive full tables in that time.

IP addresses have been changed

10.100.152.0/21 is a range we own with ARIN, it is advertised by us on Core1 and by ISP2 with a static route to Core2

10.22.236.0/23 is owned by ISP2, static route to Core2 but after the upgrade they are sending us an LOA to advertise it with ISP1

We have OSPF setup advertising all PTP and Lo addresses.

BGP has been setup between the Core routers and between the Core and Router1 routers.

Due to Router1 being a Mikrotik, it cannot accept full tables so we have filtered that out and only distribute a default route to it.

We have had reports of the internet traffic randomly dropping from our clients. We have not been able to track down what is happening exactly.

Core1

Lo 10.10.131.0

PTP to Core2 IP - 10.10.129.0/31

PTP to Router1 IP - 10.10.129.4/31

interface eno1.3202 ip ospf network point-to-point ! interface eno1d1 ip ospf cost 1 ip ospf network point-to-point ! router-id 10.10.131.0 ! router bgp 1234 no bgp default ipv4-unicast neighbor 10.10.131.1 remote-as 1234 neighbor 10.10.131.1 update-source 10.10.131.0 neighbor 10.10.131.5 remote-as 1234 neighbor 10.10.131.5 update-source 10.10.131.0 ! address-family ipv4 unicast network 10.100.152.0/21 neighbor 10.10.131.1 activate neighbor 10.10.131.5 activate neighbor 10.10.131.5 default-originate route-map GW neighbor 10.10.131.5 prefix-list defaultonly out neighbor 100.105.58.113 activate neighbor 100.105.58.113 soft-reconfiguration inbound neighbor 100.105.58.113 prefix-list infilter in neighbor 100.105.58.113 prefix-list outfilter out exit-address-family ! router ospf ospf router-id 10.10.131.0 passive-interface eno1.4003 network 10.10.129.0/31 area 0.0.0.0 network 10.10.129.4/31 area 0.0.0.0 network 10.10.131.0/31 area 0.0.0.0 ! ip prefix-list defaultonly seq 100 permit 0.0.0.0/0 ip prefix-list infilter seq 100 permit 0.0.0.0/0 le 24 ip prefix-list infilter seq 6 deny 10.22.236.0/23 le 32 ip prefix-list infilter seq 9 deny 100.192.152.0/21 le 32 ip prefix-list outfilter seq 6 permit 100.192.152.0/21 le 21 ! route-map GW permit 10 set metric 1 

Core 2

Lo 10.10.131.1

PTP to Core1 IP - 10.10.129.1/31

PTP to Router1 IP - 10.10.130.4/31

ip route 0.0.0.0/0 10.22.239.141 ! interface eno1.3402 ip ospf network point-to-point ! interface eno1d1 ip ospf cost 1 ip ospf network point-to-point ! router-id 10.10.131.1 ! router bgp 1234 neighbor 10.10.131.0 remote-as 1234 neighbor 10.10.131.0 update-source 10.10.131.1 neighbor 10.10.131.5 remote-as 1234 neighbor 10.10.131.5 update-source 10.10.131.1 ! address-family ipv4 unicast network 10.22.236.0/23 network 10.100.152.0/21 neighbor 10.10.131.1 activate neighbor 10.10.131.5 activate neighbor 10.10.131.5 default-originate route-map GW neighbor 10.10.131.5 prefix-list defaultonly out exit-address-family ! router ospf ospf router-id 10.10.131.1 passive-interface eno1.4001 network 10.10.129.0/31 area 0.0.0.0 network 10.10.130.4/31 area 0.0.0.0 network 10.10.131.1/32 area 0.0.0.0 ! ip prefix-list defaultonly seq 100 permit 0.0.0.0/0 ! route-map GW permit 10 set metric 1 

Router1

Lo 10.10.131.5

PTP to Core1 IP - 10.10.129.5/31

PTP to Core2 IP - 10.10.130.5/31

/routing bgp instance add as=1234 name=default2 router-id=10.10.131.5 /routing ospf instance set [ find default=yes ] router-id=10.10.131.5 /snmp community add addresses=0.0.0.0/0 name=snmp_f0rth3h0rd3 /ip address add address=100.192.153.1 interface=LoopBack network=100.192.153.1 add address=10.10.131.5 interface=LoopBack network=10.10.131.5 add address=10.10.129.5 interface=vlan3202 network=10.10.129.4 add address=10.10.130.5 interface=vlan3402 network=10.10.130.4 add address=192.168.255.1/24 interface=ether5 network=192.168.255.0 /ip firewall nat add action=src-nat chain=srcnat out-interface=sfp-sfpplus1 src-address=192.168.255.0/24 to-addresses=100.192.153.1 /routing bgp network add network=100.192.153.1/32 /routing bgp peer add instance=default2 name=CORE1 remote-address=10.10.131.0 remote-as=1234 ttl=default update-source=10.10.131.5 add instance=default2 name=CORE2 remote-address=10.10.131.1 remote-as=1234 ttl=default update-source=10.10.131.5 /routing ospf interface add network-type=broadcast passive=yes add interface=vlan3202 network-type=point-to-point add interface=vlan3402 network-type=point-to-point /routing ospf network add area=backbone network=10.10.129.4/31 add area=backbone network=10.10.131.5/32 add area=backbone network=10.10.130.4/31 


No comments:

Post a Comment