Hi, Would like to ask if announcing routes using network command from BGP affect the output of the mpls label? Because tried using the redistribute from IGP into BGP and the label works, not sure if this is just in GNS3 bug or something... though seen that there are method that they are using the Network command in BGP.
ASBR P2P only: PE01---PE02
######### PE 01 #########
interface GigabitEthernet3
ip address 192.168.1.1 255.255.255.252
negotiation auto
mpls bgp forwarding
no mop enabled
no mop sysid
end
PE01#sh run | sec router bgp
router bgp 20
bgp log-neighbor-changes
neighbor 192.168.1.2 remote-as 10
!
address-family ipv4
network 8.8.8.8 mask 255.255.255.255
neighbor 192.168.1.2 activate
neighbor 192.168.1.2 send-community both
neighbor 192.168.1.2 route-map RM:IB out
neighbor 192.168.1.2 send-label
exit-address-family
PE01#sh ip route 8.8.8.8
Routing entry for 8.8.8.8/32
Known via "isis", distance 115, metric 50, type level-2
PE01#sh ip route 172.1.1.11
Routing entry for 172.1.1.11/32
Known via "bgp 20", distance 20, metric 40
PE01#sh mpls forwarding-table 172.1.1.11 (FROM PEER)
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
24 No Label 172.1.1.11/3223496 Gi3 192.168.1.2
######### PE 02 #########
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.252
duplex full
mpls bgp forwarding
PE02#sh run | sec router bgp
router bgp 10
bgp log-neighbor-changes
neighbor 192.168.1.1 remote-as 20
!
address-family ipv4
no synchronization
network 172.1.1.11 mask 255.255.255.255
neighbor 192.168.1.1 activate
neighbor 192.168.1.1 send-community extended
neighbor 192.168.1.1 route-map RM:IB out
neighbor 192.168.1.1 send-label
no auto-summary
exit-address-family
Thanks
No comments:
Post a Comment