This is very strange and could be a config issue, or could be because I am using a dynamic IP. I am going to reach out to Verizon for a static IP to test, but wondering if anyone here can assist as well.
I want to take in Verizon LTE and use it as the ethernet uplink for a Meraki MX.
So far I have the router config'd and the interface is constantly bouncing and shows interface resets in the "show int cell 0". I can occasionally ping out to 8.8.8.8 when the connection is up, and I get an IP, but then it resets again and I lose it until it connects and bounces repeatedly. Past that, nothing downstream can get out at all, even when the int is up and pinging through the router, I think this is a NAT config issue below, as routing should be covered with the 0 0 cell0 rule I would think.
Here is my config:
Building configuration...
Current configuration : 6531 bytes
!
version 15.6
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
!
logging buffered 51200 warnings
!
no aaa new-model
ethernet lmi ce
!
crypto pki trustpoint TP-self-signed-1840704989
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1840704989
revocation-check none
rsakeypair TP-self-signed-1840704989
!
!
crypto pki certificate chain TP-self-signed-1840704989
certificate self-signed 01
XXXXX
quit
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.128
default-router 10.10.10.1
lease 0 2
!
!
!
no ip domain lookup
ip domain name yourdomain.com
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
chat-script lte "" "AT!CALL" TIMEOUT 20 "OK"
!
!
!
!
!
license udi pid C819HG-LTE-MNA-K9 sn FTX2137Z05V
!
!
username admin privilege 15 secret 5 *******************
!
redundancy
!
!
!
!
!
controller Cellular 0
lte sim data-profile 1 attach-profile 1 slot 0
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6
no cdp run
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 1.1.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer enable-timeout 8
dialer string lte
dialer watch-group 1
async mode interactive
!
interface Cellular1
no ip address
encapsulation slip
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0
no ip address
shutdown
clock rate 2000000
!
interface Vlan1
description $ETH_LAN$
ip address 10.10.10.1 255.255.255.128
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source static 10.10.10.3 100.69.6.199
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
ipv6 ioam timestamp
!
route-map NAT permit 10
match ip address 199
match interface Cellular0
!
access-list 23 permit 10.10.10.0 0.0.0.127
access-list 199 permit ip any any
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
login local
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line 3
script dialer lte
modem InOut
no exec
rxspeed 100000000
txspeed 50000000
line 8
no exec
rxspeed 100000000
txspeed 50000000
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
!
!
!
!
!
end
No comments:
Post a Comment