Friday, June 29, 2018

Mikrotik MPLS Sanity Check

Could we get a sanity check on our config? We have our Core router CCR1072 with a 10Gb uplink to the internet (sfp-sfpplus1 vlan 803) . We have a 1GB fiber connection from the Core router (sfp-sfpplus3 vlan 3000) to SW1 CRS112 (ether1 vlan 3000). We then have a wireless Ubiquiti rocket AC lite link between SW1 (ether2) and SW2 CRS112 (ether1). The fiber link has a max MTU of 8900. The wireless link has a max MTU of 2024. We set the different interfaces on the Mikrotik router and switches to the max MTU supported by that link.

Download speeds before MPLS configuration was around 500Mb down at SW1 and 200Mb at SW2. After MPLS it dropped to 90Mb at both SW1 and SW2. We are eventually wanting to setup redundant wireless links and expand MPLS out to our other towers. We are not seeing any errors on any devices.

We did try disabling MPLS on SW1 and the Core with no improvement in download speed. Also, using a VPLS tunnel instead of a EoOP tunnel resulted in slower speeds.

Upon further research, It looks like the tutorial I read that recommended changing MTU to the max supported by the backhauls may not have been correct. Or at least it should not have had me set all the MTUs the same. Could this be the issue?

Core1

/interface bridge add fast-forward=no name=LoopBack add name=PIP protocol-mode=none /interface ethernet set [ find default-name=sfp-sfpplus3 ] l2mtu=8900 mtu=8900 /interface eoip add !keepalive mac-address=02:1C:12:38:E8:41 name=Core1-to-SW2 remote-address=10.200.0.3 tunnel-id=1 add !keepalive mac-address=02:8D:48:7D:E2:7D name=Core1-to-SW1 remote-address=10.200.0.2 tunnel-id=0 /interface vlan add comment="MPLS" interface=sfp-sfpplus3 name="vlan3000" vlan-id=3000 add interface=sfp-sfpplus1 name=vlan803 vlan-id=803 /routing ospf instance set [ find default=yes ] distribute-default=always-as-type-1 mpls-te-area=backbone mpls-te-router-id=LoopBack redistribute-other-ospf=as-type-1 router-id=10.200.0.1 /interface bridge port add bridge=PIP interface=Core1-to-SW1 add bridge=PIP interface=Core1-to-SW2 /ip address add address=10.255.0.2/30 interface=vlan803 network=10.255.0.0 add address=10.20.0.1/22 interface=PIP network=10.20.0.0 add address=10.0.0.1/30 interface="LanLink - vlan3000" network=10.0.0.0 /ip firewall nat add action=src-nat chain=srcnat out-interface=vlan803 src-address=10.20.0.0/22 to-addresses=x.x.157.1 /ip route add distance=1 gateway=10.255.0.1 /mpls interface set [ find default=yes ] mpls-mtu=8900 /mpls ldp set enabled=yes lsr-id=10.200.0.1 transport-address=10.200.0.1 /mpls ldp interface add interface="vlan3000" /routing ospf interface add interface="LanLink - vlan3000" network-type=point-to-point use-bfd=yes /routing ospf network add area=backbone network=10.200.0.1/32 add area=backbone network=10.0.0.0/30 /system identity set name=Core1 

SW1

/interface bridge add fast-forward=no name=LoopBack add name=PIP protocol-mode=none /interface ethernet set [ find default-name=ether1 ] l2mtu=8900 mtu=8900 set [ find default-name=ether2 ] l2mtu=2024 mtu=2024 /interface eoip add !keepalive mac-address=02:A3:ED:52:A3:C9 name=Core-to-SW1 remote-address=10.200.0.1 tunnel-id=0 /interface vlan add interface=ether1 name=vlan3000 vlan-id=3000 /routing ospf instance set [ find default=yes ] mpls-te-area=backbone mpls-te-router-id=LoopBack redistribute-other-ospf=as-type-1 router-id=10.200.0.2 /interface bridge port add bridge=PIP interface=Core1-to-SW1 add bridge=PIP interface=ether3 add bridge=PIP interface=ether4 add bridge=PIP interface=ether5 add bridge=PIP interface=ether6 add bridge=PIP interface=ether2 /ip address add address=10.0.0.2/30 interface=vlan3000 network=10.0.0.0 add address=10.200.0.2 interface=LoopBack network=10.200.0.2 add address=10.100.0.1/29 interface=ether2 network=10.100.0.0 /mpls interface set [ find default=yes ] mpls-mtu=2024 /mpls ldp set enabled=yes lsr-id=10.200.0.2 transport-address=10.200.0.2 /mpls ldp interface add interface=vlan3000 add interface=ether2 /routing ospf interface add interface=vlan3000 network-type=point-to-point use-bfd=yes add interface=ether2 network-type=point-to-point use-bfd=yes /routing ospf network add area=backbone network=10.200.0.2/32 add area=backbone network=10.0.0.0/30 add area=backbone network=10.100.0.0/29 /system identity set name=SW1 

SW2

/interface bridge add fast-forward=no name=LoopBack add name=PIP protocol-mode=none /interface ethernet set [ find default-name=ether2 ] l2mtu=2024 mtu=2024 set [ find default-name=ether3 ] set [ find default-name=ether4 ] l2mtu=2024 mtu=2024 set [ find default-name=ether5 ] /interface eoip add !keepalive mac-address=02:3C:BA:67:20:97 name=Core1-to-SW2 remote-address=10.200.0.1 tunnel-id=1 /routing ospf instance set [ find default=yes ] mpls-te-area=backbone mpls-te-router-id=LoopBack redistribute-other-ospf=as-type-1 router-id=10.200.0.3 /interface bridge port add bridge=PIP interface=Core1-to-SW2 add bridge=PIP interface=ether3 add bridge=PIP interface=ether4 add bridge=PIP interface=ether5 /ip address add address=10.100.0.4/29 interface=ether2 network=10.100.0.0 add address=10.200.0.3 interface=LoopBack network=10.200.0.3 /mpls interface set [ find default=yes ] mpls-mtu=2024 /mpls ldp set enabled=yes lsr-id=10.200.0.3 transport-address=10.200.0.3 /mpls ldp interface add interface=ether2 /routing ospf interface add interface=ether2 network-type=point-to-point use-bfd=yes /routing ospf network add area=backbone network=10.200.0.3/32 add area=backbone network=10.100.0.0/29 /system identity set name=SW2 


No comments:

Post a Comment